티스토리 뷰



 No acceptable module found. Local version is 0 and remote version is 0.



this problem has due to there is no playstore in phone of user when you using firebase library

if you guiding to install playstore to user. it is would be solved.

if already installed playstore, have to version update


해당 폰에 플레이스토어가 없어서 생기는 문제다.

firebase를 적용하면서 오류가 발생했는데 이전의 구형폰들은 안드로이드 마켓이 깔려있기 때문이다.

플레이스토어를 설치하도록 유도하여 플레이스토어가 설치가 된다면 해결될 것.


이미 플레이스토어가 설치되어 있더라도 9.2.0 이상의 버전이 설치되어 있어야 한다.


구현코드는 아래와 같다.


GoogleApiAvailability api = GoogleApiAvailability.getInstance();
int code = GoogleApiAvailability.getInstance().isGooglePlayServicesAvailable(activity);
if (code == ConnectionResult.SUCCESS) {
return true;
} else {
api.getErrorDialog(activity, code, 0).show();
return false;
}


댓글
댓글쓰기 폼